aboutsummaryrefslogtreecommitdiffstats
path: root/community/karchive/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/karchive/APKBUILD')
-rw-r--r--community/karchive/APKBUILD43
1 files changed, 29 insertions, 14 deletions
diff --git a/community/karchive/APKBUILD b/community/karchive/APKBUILD
index 4e51c2924bb..a7b988fa32f 100644
--- a/community/karchive/APKBUILD
+++ b/community/karchive/APKBUILD
@@ -1,20 +1,35 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=karchive
-pkgver=5.84.0
+pkgver=6.0.0
pkgrel=0
-pkgdesc="Qt 5 addon providing access to numerous types of archives"
-arch="all !armhf" # qtdeclarative
+pkgdesc="Qt addon providing access to numerous types of archives"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
-license="LGPL-2.0-only AND LGPL-2.1-or-later"
-depends_dev="bzip2-dev xz-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen graphviz qt5-qttools-dev"
+license="LGPL-2.0-or-later AND LGPL-2.1-or-later"
+depends_dev="
+ bzip2-dev
+ qt6-qtbase-dev
+ xz-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ graphviz
+ qt6-qttools-dev
+ samurai
+ "
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/karchive.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/karchive-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -22,13 +37,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-2aad7a9920942b2a458aa5ab85c13f0671c924e99a04803eba056c339d426ed6dad1706d83c7bb8169bab69fc79d1a3ff064b6c6dfcc029d2d6b842dbd58ea86 karchive-5.84.0.tar.xz
+b4bb87908d53691f0694c4cbdee60e0ee27f3881760dce762d997f9e9f2fba73d9c4a7d9e4583cd2f5f4be905ee30254876d94da23f1e78052dae207689fa5ed karchive-6.0.0.tar.xz
"