aboutsummaryrefslogtreecommitdiffstats
path: root/community/karchive/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/karchive/APKBUILD')
-rw-r--r--community/karchive/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/community/karchive/APKBUILD b/community/karchive/APKBUILD
index 286069015c6..af4eda44c73 100644
--- a/community/karchive/APKBUILD
+++ b/community/karchive/APKBUILD
@@ -1,26 +1,31 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=karchive
-pkgver=5.97.0
+pkgver=6.1.0
pkgrel=0
-pkgdesc="Qt5 addon providing access to numerous types of archives"
+pkgdesc="Qt addon providing access to numerous types of archives"
# armhf blocked by extra-cmake-modules
arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later AND LGPL-2.1-or-later"
depends_dev="
bzip2-dev
+ qt6-qtbase-dev
xz-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
graphviz
- qt5-qttools-dev
+ qt6-qttools-dev
samurai
"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/karchive.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/karchive-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc"
build() {
cmake -B build -G Ninja \
@@ -32,8 +37,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -41,5 +45,5 @@ package() {
}
sha512sums="
-0d19ecbe8baf3c07de02c78b6b6a06650c86073b264676b658553f84aeb258941ef927fa7297786a0b777d9e5db7c9613776b3ade48896e8324878791ecfbe13 karchive-5.97.0.tar.xz
+14af2a3335de1ef320f838a8dc4176cfea9fc861576ea6ba3e8d072d422432b08d5e01fa2c681b26e11798da4970749516785d7dbaf5f4137c2b2bcb45f62f12 karchive-6.1.0.tar.xz
"