aboutsummaryrefslogtreecommitdiffstats
path: root/community/karchive/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/karchive/APKBUILD')
-rw-r--r--community/karchive/APKBUILD26
1 files changed, 16 insertions, 10 deletions
diff --git a/community/karchive/APKBUILD b/community/karchive/APKBUILD
index 943bdce29aa..af4eda44c73 100644
--- a/community/karchive/APKBUILD
+++ b/community/karchive/APKBUILD
@@ -1,29 +1,35 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=karchive
-pkgver=5.88.0
+pkgver=6.1.0
pkgrel=0
-pkgdesc="Qt5 addon providing access to numerous types of archives"
+pkgdesc="Qt addon providing access to numerous types of archives"
# armhf blocked by extra-cmake-modules
arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later AND LGPL-2.1-or-later"
depends_dev="
bzip2-dev
+ qt6-qtbase-dev
xz-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
graphviz
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/karchive.git"
source="https://download.kde.org/stable/frameworks/${pkgver%.*}/karchive-$pkgver.tar.xz"
-subpackages="$pkgname-dev $pkgname-doc"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -31,13 +37,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-c24712bf112870dda73d61574155c3858f10283d7692bea5a588f3138017b15883a9c81f7a5b1f6763df3efd7b08886c77fbef4320c8c0dd25c57e2d6e4a6560 karchive-5.88.0.tar.xz
+14af2a3335de1ef320f838a8dc4176cfea9fc861576ea6ba3e8d072d422432b08d5e01fa2c681b26e11798da4970749516785d7dbaf5f4137c2b2bcb45f62f12 karchive-6.1.0.tar.xz
"