aboutsummaryrefslogtreecommitdiffstats
path: root/community/katomic/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/katomic/APKBUILD')
-rw-r--r--community/katomic/APKBUILD23
1 files changed, 12 insertions, 11 deletions
diff --git a/community/katomic/APKBUILD b/community/katomic/APKBUILD
index 3546a188c2b..1c1fa3148d0 100644
--- a/community/katomic/APKBUILD
+++ b/community/katomic/APKBUILD
@@ -1,17 +1,19 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=katomic
-pkgver=22.04.0
-pkgrel=1
+pkgver=24.02.1
+pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/games/org.kde.katomic"
pkgdesc="A fun and educational game built around molecular geometry"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
- qt5-qtbase-dev
+ qt6-qtbase-dev
kcoreaddons-dev
kconfig-dev
kcrash-dev
@@ -24,9 +26,9 @@ makedepends="
libkdegames-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/katomic-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/katomic.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/katomic-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -37,8 +39,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -46,5 +47,5 @@ package() {
}
sha512sums="
-a0c362eda5c9b2579f0cb244bd5fa82f6646a4a5823bcfb9ca244060b7b5033ae47d91202127ebf3c29403dca8afed67c2114cf6e76133635d1e90533b2d07fd katomic-22.04.0.tar.xz
+7ae62e8b0bc99a361e51e126cddaac34c4a82f6aa98f8c96793c103e03f429be339c78bf3f4b2b102df5ef7eed83a2c71b451f9c3982a656a344d90debcdd07f katomic-24.02.1.tar.xz
"