aboutsummaryrefslogtreecommitdiffstats
path: root/community/katomic/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/katomic/APKBUILD')
-rw-r--r--community/katomic/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/katomic/APKBUILD b/community/katomic/APKBUILD
index d834284ec14..1c1fa3148d0 100644
--- a/community/katomic/APKBUILD
+++ b/community/katomic/APKBUILD
@@ -1,17 +1,19 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=katomic
-pkgver=20.08.3
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64 and s390x blocked by kconfigwidgets
-arch="all !armhf !mips64 !s390x"
+arch="all !armhf"
url="https://kde.org/applications/games/org.kde.katomic"
pkgdesc="A fun and educational game built around molecular geometry"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
- qt5-qtbase-dev
+ qt6-qtbase-dev
kcoreaddons-dev
kconfig-dev
kcrash-dev
@@ -22,26 +24,28 @@ makedepends="
kdoctools-dev
kdbusaddons-dev
libkdegames-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/katomic-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/katomic.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/katomic-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="6e39c495b8ed55af7e3135132e4c402ddda7d62f70f46b3021f99ef47ba9444522d0adf824113ad0fcc6bf764550e234a9d3ee833a1a11a3c601de982cc5e90b katomic-20.08.3.tar.xz"
+sha512sums="
+7ae62e8b0bc99a361e51e126cddaac34c4a82f6aa98f8c96793c103e03f429be339c78bf3f4b2b102df5ef7eed83a2c71b451f9c3982a656a344d90debcdd07f katomic-24.02.1.tar.xz
+"