aboutsummaryrefslogtreecommitdiffstats
path: root/community/katomic/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/katomic/APKBUILD')
-rw-r--r--community/katomic/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/katomic/APKBUILD b/community/katomic/APKBUILD
index 7a2db7aa53d..3207f773436 100644
--- a/community/katomic/APKBUILD
+++ b/community/katomic/APKBUILD
@@ -1,17 +1,19 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=katomic
-pkgver=20.12.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# mips64 and s390x blocked by kconfigwidgets
-arch="all !armhf !mips64 !s390x"
+arch="all !armhf"
url="https://kde.org/applications/games/org.kde.katomic"
pkgdesc="A fun and educational game built around molecular geometry"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
- qt5-qtbase-dev
+ qt6-qtbase-dev
kcoreaddons-dev
kconfig-dev
kcrash-dev
@@ -22,26 +24,28 @@ makedepends="
kdoctools-dev
kdbusaddons-dev
libkdegames-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/katomic-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/games/katomic.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/katomic-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="851f17d6fc220d72f0680c0312bf59e622b7c727dc6823a97051e76a43c7bedab6aa505a3d51b9d11eed991badcd37e15831ced279c4678fa6a24c7623208e83 katomic-20.12.2.tar.xz"
+sha512sums="
+28ee05fbb6cab1f19d7a6cf981e34f05923e457e192eec708073d64b9eb3a28c1f245c7882e8fb979b8de24f1928448a50c6dac4c1d384b502f7ca0cc8e1ae7e katomic-24.02.2.tar.xz
+"