aboutsummaryrefslogtreecommitdiffstats
path: root/community/kauth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kauth/APKBUILD')
-rw-r--r--community/kauth/APKBUILD25
1 files changed, 14 insertions, 11 deletions
diff --git a/community/kauth/APKBUILD b/community/kauth/APKBUILD
index dd504813c9d..78d626e24e0 100644
--- a/community/kauth/APKBUILD
+++ b/community/kauth/APKBUILD
@@ -1,28 +1,32 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kauth
-pkgver=5.96.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Abstraction to system policy and authentication features"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
kcoreaddons-dev
- polkit-qt-1-dev
- qt5-qtbase-dev
+ kwindowsystem-dev
+ polkit-qt-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
graphviz
- qt5-qttools-dev
+ qt6-qttools-dev
samurai
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kauth-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kauth.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kauth-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -34,9 +38,8 @@ build() {
}
check() {
- cd build
# KAuthHelperTest hangs
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(KAuthHelperTest)'
+ ctest --test-dir build --output-on-failure -E '(KAuthHelperTest)'
}
package() {
@@ -44,5 +47,5 @@ package() {
}
sha512sums="
-ebee1ba35b3dfa439b79c1aab6a51ec968837253e07e913edb4813214744427baffa5d2be661d66f40c7c25b09184dc6dea1773854caede1a263327d9f582204 kauth-5.96.0.tar.xz
+c9c13280cada75ec2f8b2e6add95ab2afe8086b16b3a8d464722202ea97c86e107395abfaac690fa77934fdf2e98eab9c60c31d000ecb7f1c62636af9abe0e6d kauth-6.1.0.tar.xz
"