aboutsummaryrefslogtreecommitdiffstats
path: root/community/kauth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kauth/APKBUILD')
-rw-r--r--community/kauth/APKBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/community/kauth/APKBUILD b/community/kauth/APKBUILD
index 55d51906f43..78d626e24e0 100644
--- a/community/kauth/APKBUILD
+++ b/community/kauth/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kauth
-pkgver=5.97.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Abstraction to system policy and authentication features"
# armhf blocked by extra-cmake-modules
@@ -10,18 +13,20 @@ url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
kcoreaddons-dev
- polkit-qt-1-dev
- qt5-qtbase-dev
+ kwindowsystem-dev
+ polkit-qt-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
graphviz
- qt5-qttools-dev
+ qt6-qttools-dev
samurai
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kauth-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kauth.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kauth-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -33,9 +38,8 @@ build() {
}
check() {
- cd build
# KAuthHelperTest hangs
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(KAuthHelperTest)'
+ ctest --test-dir build --output-on-failure -E '(KAuthHelperTest)'
}
package() {
@@ -43,5 +47,5 @@ package() {
}
sha512sums="
-07cf6d5ed1225f103a1eba9bea0f1ae6e35bcd0ffc475ca655deff8c583f59a14bd16a1d8e15b07d5e8dfac4305a39731a68ec5d7118d8de1263e9e2487d053f kauth-5.97.0.tar.xz
+c9c13280cada75ec2f8b2e6add95ab2afe8086b16b3a8d464722202ea97c86e107395abfaac690fa77934fdf2e98eab9c60c31d000ecb7f1c62636af9abe0e6d kauth-6.1.0.tar.xz
"