aboutsummaryrefslogtreecommitdiffstats
path: root/community/kauth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kauth/APKBUILD')
-rw-r--r--community/kauth/APKBUILD54
1 files changed, 32 insertions, 22 deletions
diff --git a/community/kauth/APKBUILD b/community/kauth/APKBUILD
index ca6914b88df..78d626e24e0 100644
--- a/community/kauth/APKBUILD
+++ b/community/kauth/APKBUILD
@@ -1,41 +1,51 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kauth
-pkgver=5.67.0
-pkgrel=1
+pkgver=6.1.0
+pkgrel=0
pkgdesc="Abstraction to system policy and authentication features"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
-depends_dev="qt5-qtbase-dev kcoreaddons-dev polkit-qt-1-dev"
-makedepends="$depends_dev extra-cmake-modules qt5-qttools-dev doxygen"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kauth-$pkgver.tar.xz"
+depends_dev="
+ kcoreaddons-dev
+ kwindowsystem-dev
+ polkit-qt-dev
+ qt6-qtbase-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ graphviz
+ qt6-qttools-dev
+ samurai
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-
-prepare() {
- default_prepare
-
- mkdir "$builddir"/build
-}
+_repo_url="https://invent.kde.org/frameworks/kauth.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kauth-$pkgver.tar.xz"
build() {
- cd "$builddir"/build
- cmake "$builddir" \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
- make
+ cmake --build build
}
check() {
- cd "$builddir"/build
# KAuthHelperTest hangs
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(KAuthHelperTest)'
+ ctest --test-dir build --output-on-failure -E '(KAuthHelperTest)'
}
package() {
- cd "$builddir"/build
- DESTDIR="$pkgdir" make install
+ DESTDIR="$pkgdir" cmake --install build
}
-sha512sums="f4ed8ffd339c5c7ce3cd974cbdee3ce4a4b766062bf3ad2845596317ea8bc27460767ca48c8a7262cc5778a130d957221612a4b0329ea735ca2b175e209669a5 kauth-5.67.0.tar.xz"
+
+sha512sums="
+c9c13280cada75ec2f8b2e6add95ab2afe8086b16b3a8d464722202ea97c86e107395abfaac690fa77934fdf2e98eab9c60c31d000ecb7f1c62636af9abe0e6d kauth-6.1.0.tar.xz
+"