aboutsummaryrefslogtreecommitdiffstats
path: root/community/kauth/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kauth/APKBUILD')
-rw-r--r--community/kauth/APKBUILD30
1 files changed, 17 insertions, 13 deletions
diff --git a/community/kauth/APKBUILD b/community/kauth/APKBUILD
index cee244e6e7c..78d626e24e0 100644
--- a/community/kauth/APKBUILD
+++ b/community/kauth/APKBUILD
@@ -1,31 +1,36 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kauth
-pkgver=5.90.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Abstraction to system policy and authentication features"
# armhf blocked by extra-cmake-modules
-# mips, mips64, s390x and riscv64 blocked by polkit
-arch="all !armhf !mips !mips64 !s390x !riscv64"
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
kcoreaddons-dev
- polkit-qt-1-dev
- qt5-qtbase-dev
+ kwindowsystem-dev
+ polkit-qt-dev
+ qt6-qtbase-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
graphviz
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kauth-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kauth.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kauth-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -33,9 +38,8 @@ build() {
}
check() {
- cd build
# KAuthHelperTest hangs
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E '(KAuthHelperTest)'
+ ctest --test-dir build --output-on-failure -E '(KAuthHelperTest)'
}
package() {
@@ -43,5 +47,5 @@ package() {
}
sha512sums="
-2a60e4ebd4ed649d8f37b11da9717047f1ce67a567ed7dff77bef9fe0c8d6ed11b2d0b493bf116974de5c8d591a69c4422ba3c71e37a56102775f35fe89b409d kauth-5.90.0.tar.xz
+c9c13280cada75ec2f8b2e6add95ab2afe8086b16b3a8d464722202ea97c86e107395abfaac690fa77934fdf2e98eab9c60c31d000ecb7f1c62636af9abe0e6d kauth-6.1.0.tar.xz
"