aboutsummaryrefslogtreecommitdiffstats
path: root/community/kbackup/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kbackup/APKBUILD')
-rw-r--r--community/kbackup/APKBUILD20
1 files changed, 12 insertions, 8 deletions
diff --git a/community/kbackup/APKBUILD b/community/kbackup/APKBUILD
index 78f537a6488..d5300e22e8a 100644
--- a/community/kbackup/APKBUILD
+++ b/community/kbackup/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kbackup
-pkgver=22.08.0
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
arch="all !armhf"
@@ -16,15 +19,17 @@ makedepends="
kiconthemes-dev
kio-dev
knotifications-dev
+ kstatusnotifieritem-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
+ libarchive-dev
+ qt6-qtbase-dev
samurai
shared-mime-info
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kbackup-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/utilities/kbackup.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kbackup-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -35,8 +40,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -44,5 +48,5 @@ package() {
}
sha512sums="
-305dc4066d200393fda316000750a97c7a2639358bd5ed73cae92472537ee97f4f8eb06f86a8e79535e42585b12d8599c8e2398855c92e16c3c350ef617e7392 kbackup-22.08.0.tar.xz
+b0e5fdfab6a9a6c3d8a72caa288532c6b02266d6360ba4ab42c7692ed01e17e1008091bbc6a7f3e7e6d87eb99b931eec6e38f1030aca6d2c9377816d2f4c9823 kbackup-24.02.2.tar.xz
"