aboutsummaryrefslogtreecommitdiffstats
path: root/community/kbackup/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kbackup/APKBUILD')
-rw-r--r--community/kbackup/APKBUILD28
1 files changed, 16 insertions, 12 deletions
diff --git a/community/kbackup/APKBUILD b/community/kbackup/APKBUILD
index a4d18a6b5ae..d5300e22e8a 100644
--- a/community/kbackup/APKBUILD
+++ b/community/kbackup/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kbackup
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.kbackup"
pkgdesc="An application which lets you back up your data in a simple, user friendly way"
license="GPL-2.0-only"
@@ -17,26 +19,28 @@ makedepends="
kiconthemes-dev
kio-dev
knotifications-dev
+ kstatusnotifieritem-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
+ libarchive-dev
+ qt6-qtbase-dev
+ samurai
shared-mime-info
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kbackup-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/utilities/kbackup.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kbackup-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -44,5 +48,5 @@ package() {
}
sha512sums="
-9e22a8d99c67eb0de712abcff5c2eea5abfccc4aee855ce6eaab48fb0d905b5d02a3a605abce1cae24127f2585906e25f9eaf4a53074f48273ddebbb59f8391b kbackup-21.08.3.tar.xz
+b0e5fdfab6a9a6c3d8a72caa288532c6b02266d6360ba4ab42c7692ed01e17e1008091bbc6a7f3e7e6d87eb99b931eec6e38f1030aca6d2c9377816d2f4c9823 kbackup-24.02.2.tar.xz
"