aboutsummaryrefslogtreecommitdiffstats
path: root/community/kblocks/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kblocks/APKBUILD')
-rw-r--r--community/kblocks/APKBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/community/kblocks/APKBUILD b/community/kblocks/APKBUILD
index 0a64a1b0855..550e696969e 100644
--- a/community/kblocks/APKBUILD
+++ b/community/kblocks/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kblocks
-pkgver=22.04.2
+pkgver=24.02.1
pkgrel=0
-# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !riscv64"
-url="https://kde.org/applications/games/kblocks/"
pkgdesc="The classic falling blocks game"
+url="https://kde.org/applications/games/kblocks/"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
@@ -21,13 +23,14 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kblocks-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/games/kblocks.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kblocks-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -38,8 +41,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -47,5 +49,5 @@ package() {
}
sha512sums="
-bc8922f0c5408867f105c4f9e6987525f88fd2092631e546e599aa25043adc3cc06103b882f44ee47362576cf12ed9dc8c1ff6ec5d5df349c67bea5b42663e19 kblocks-22.04.2.tar.xz
+2cb670e71c199ec52dbb3293f01d2fdbab6ba115d0e22d8ad029c25826bbec9a2f71168e45fc8d1c0e09ef10c53ddb0b3efd047c30b412b05f25038bec0c9ac7 kblocks-24.02.1.tar.xz
"