aboutsummaryrefslogtreecommitdiffstats
path: root/community/kblocks/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kblocks/APKBUILD')
-rw-r--r--community/kblocks/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/kblocks/APKBUILD b/community/kblocks/APKBUILD
index 2429bb2c60d..550e696969e 100644
--- a/community/kblocks/APKBUILD
+++ b/community/kblocks/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kblocks
-pkgver=22.08.0
+pkgver=24.02.1
pkgrel=0
pkgdesc="The classic falling blocks game"
url="https://kde.org/applications/games/kblocks/"
@@ -20,13 +23,14 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kblocks-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/games/kblocks.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kblocks-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -37,8 +41,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -46,5 +49,5 @@ package() {
}
sha512sums="
-4e6501ee32452cc1e47467de4791005d9fb3a9296452f42910fe212a97c35af21af7ba8b11e616e45bff6456fdcc7430a12f8b2ab83b74dc28af651ecd9fcc87 kblocks-22.08.0.tar.xz
+2cb670e71c199ec52dbb3293f01d2fdbab6ba115d0e22d8ad029c25826bbec9a2f71168e45fc8d1c0e09ef10c53ddb0b3efd047c30b412b05f25038bec0c9ac7 kblocks-24.02.1.tar.xz
"