aboutsummaryrefslogtreecommitdiffstats
path: root/community/kblocks/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kblocks/APKBUILD')
-rw-r--r--community/kblocks/APKBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/community/kblocks/APKBUILD b/community/kblocks/APKBUILD
index 98dac9b8769..dbb18972991 100644
--- a/community/kblocks/APKBUILD
+++ b/community/kblocks/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kblocks
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
-# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
-url="https://kde.org/applications/games/kblocks/"
pkgdesc="The classic falling blocks game"
+url="https://kde.org/applications/games/kblocks/"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
@@ -21,24 +23,25 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kblocks-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/games/kblocks.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kblocks-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -46,5 +49,5 @@ package() {
}
sha512sums="
-88e7eca4f5dd07b4f1d0190db1cadcf795f7b4b372451f8352fb1bc7f2e97ab2f9e38a85a192b358489132502837496a604c2484e2cda32eab87a5e4997fdb8a kblocks-21.08.3.tar.xz
+d4ea2cfc0b97f5afcdddaf726886904952ddf39dc3ff2bfdfda668c18b28d9269a529c03a10145aa5198ec8fa7df5738724f805e894fe9190cac857b5995242d kblocks-24.02.2.tar.xz
"