aboutsummaryrefslogtreecommitdiffstats
path: root/community/kbounce/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kbounce/APKBUILD')
-rw-r--r--community/kbounce/APKBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/community/kbounce/APKBUILD b/community/kbounce/APKBUILD
index 9fd48276f1c..86eb6629486 100644
--- a/community/kbounce/APKBUILD
+++ b/community/kbounce/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kbounce
-pkgver=21.04.3
+pkgver=24.02.1
pkgrel=0
-# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
-url="https://kde.org/applications/games/kbounce/"
pkgdesc="A single player arcade game with the elements of puzzle"
+url="https://kde.org/applications/games/kbounce/"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
@@ -23,23 +25,24 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kbounce-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/games/kbounce.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kbounce-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -47,5 +50,5 @@ package() {
}
sha512sums="
-abd045e3af6e6b65d125e863b9d8814b30a0a0e99137820b5dbc334ff172479c0d67a023bd97c323d2764ebaaa0ebcc6e3d4f8e0b2d4c0f29dbbc85b95b2a3e0 kbounce-21.04.3.tar.xz
+66a0800d1487e0fb5589d200c7f22ea6571498b85db76e08681cf22479a59d3384e22b76eb4204fd5a788c8eca27fa92fcbcbe8c6ea782e2afc05c5f164e332a kbounce-24.02.1.tar.xz
"