aboutsummaryrefslogtreecommitdiffstats
path: root/community/kbounce/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kbounce/APKBUILD')
-rw-r--r--community/kbounce/APKBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/community/kbounce/APKBUILD b/community/kbounce/APKBUILD
index 2833b8448f7..a027780ef14 100644
--- a/community/kbounce/APKBUILD
+++ b/community/kbounce/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kbounce
-pkgver=21.12.1
+pkgver=24.02.2
pkgrel=0
-# armhf blocked by extra-cmake-modules
-# mips64, s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !mips64 !s390x !riscv64"
-url="https://kde.org/applications/games/kbounce/"
pkgdesc="A single player arcade game with the elements of puzzle"
+url="https://kde.org/applications/games/kbounce/"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
license="GPL-2.0-or-later AND LGPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
@@ -23,23 +25,24 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtsvg-dev
+ qt6-qtbase-dev
+ qt6-qtsvg-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kbounce-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/games/kbounce.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kbounce-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -47,5 +50,5 @@ package() {
}
sha512sums="
-d462a2461384338d9335ed08c034d258020d875fcc7593e55c052da877d93c50b58f956f387a5198e0166fefa0dc90c244d85c54f16c397086d6f85dd755ea01 kbounce-21.12.1.tar.xz
+49c16f486a2ab8832cde731f36f1a2ff3052142362084e109a5e17a9703995187814718bfe779eb58f52ceacfe635ed3117cdcc0531d6a0e290c91a73a06b7cc kbounce-24.02.2.tar.xz
"