aboutsummaryrefslogtreecommitdiffstats
path: root/community/kbreakout/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kbreakout/APKBUILD')
-rw-r--r--community/kbreakout/APKBUILD31
1 files changed, 17 insertions, 14 deletions
diff --git a/community/kbreakout/APKBUILD b/community/kbreakout/APKBUILD
index 5b85973320c..53f4f436ce9 100644
--- a/community/kbreakout/APKBUILD
+++ b/community/kbreakout/APKBUILD
@@ -1,13 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kbreakout
-pkgver=21.04.3
+pkgver=24.02.2
pkgrel=0
-# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
-url="https://kde.org/applications/games/kbreakout/"
pkgdesc="A Breakout-like game"
+url="https://kde.org/applications/games/kbreakout/"
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="
extra-cmake-modules
@@ -21,23 +23,24 @@ makedepends="
kwidgetsaddons-dev
kxmlgui-dev
libkdegames-dev
- qt5-qtbase-dev
- qt5-qtdeclarative-dev
+ qt6-qtbase-dev
+ qt6-qtdeclarative-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kbreakout-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/games/kbreakout.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kbreakout-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -45,5 +48,5 @@ package() {
}
sha512sums="
-0f72faaf376a239c5d107dd4b45c0d0bff9a8710fca018e1ed0e519b087570c5b3679c00556b2a21feddcba8b3a182d2209b42fc8b3ff5785e0dff863b53942a kbreakout-21.04.3.tar.xz
+7beea15ff0b4ef83e947ff356fd74726d1c35c76e3680b805bc61789d45874b4b8eeb0193bd21bbcf88046b96c65ffc9f8d12742e50bcc34d51b71b48b6625ae kbreakout-24.02.2.tar.xz
"