aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcachegrind/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcachegrind/APKBUILD')
-rw-r--r--community/kcachegrind/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/community/kcachegrind/APKBUILD b/community/kcachegrind/APKBUILD
index cb0ec7d9563..e1d9d2b42b1 100644
--- a/community/kcachegrind/APKBUILD
+++ b/community/kcachegrind/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcachegrind
-pkgver=21.12.1
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and risc64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/development/org.kde.kcachegrind"
pkgdesc="A profile data visualization tool, used to determine the most time consuming parts in the execution of a program"
license="GPL-2.0-only AND GFDL-1.2-only"
@@ -20,24 +22,24 @@ makedepends="
kio-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
- qt5-qttools-dev
+ qt6-qtbase-dev
+ qt6-qttools-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcachegrind-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/sdk/kcachegrind.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcachegrind-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -45,5 +47,5 @@ package() {
}
sha512sums="
-b0e5d60627ab180a62a278b3291f8714e20340553e8ff050875922fb5ab23e868b38d89f137dddae91787914ca84977afe840e4e3e3206a543de32d2fdda892d kcachegrind-21.12.1.tar.xz
+23c4642e70356e0abe1909e4b286549e1b1bf85b763336f4d82eae814be9c321be07319bf98fa5b6cd5b57359e4473a74870ebf774591236357b31720eadc3e2 kcachegrind-24.02.1.tar.xz
"