aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcachegrind/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcachegrind/APKBUILD')
-rw-r--r--community/kcachegrind/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/community/kcachegrind/APKBUILD b/community/kcachegrind/APKBUILD
index 191fe9ee62b..2bf9706eb3b 100644
--- a/community/kcachegrind/APKBUILD
+++ b/community/kcachegrind/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcachegrind
-pkgver=21.08.2
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and risc64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/development/org.kde.kcachegrind"
pkgdesc="A profile data visualization tool, used to determine the most time consuming parts in the execution of a program"
license="GPL-2.0-only AND GFDL-1.2-only"
@@ -20,24 +22,24 @@ makedepends="
kio-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
- qt5-qttools-dev
+ qt6-qtbase-dev
+ qt6-qttools-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcachegrind-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/sdk/kcachegrind.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcachegrind-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -45,5 +47,5 @@ package() {
}
sha512sums="
-8ac0f72c1382fb1462ddfaf3ce3c9f42f84c126a02ad633c9b7f4861b9960b8d4e2cdc3481409f0ee1a9edd32929e24b9ce3ed0df7d4347de4baa35f3169c6a5 kcachegrind-21.08.2.tar.xz
+8b039a6bc9242e7ea0ae8ad782074941a6b46a18551088ea62101e4b5a9782871a02843464c3ea457e749cd16cf96d46d9bf26af0977fa1145ee6f77ac6a9353 kcachegrind-24.02.2.tar.xz
"