aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcalc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcalc/APKBUILD')
-rw-r--r--community/kcalc/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/community/kcalc/APKBUILD b/community/kcalc/APKBUILD
index 2fe4d53209c..3e0eb419405 100644
--- a/community/kcalc/APKBUILD
+++ b/community/kcalc/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcalc
-pkgver=22.08.0
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
arch="all !armhf"
@@ -17,15 +20,15 @@ makedepends="
kdoctools-dev
kguiaddons-dev
ki18n-dev
- kinit-dev
knotifications-dev
kxmlgui-dev
mpfr-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcalc-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/kcalc.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcalc-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -36,8 +39,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -45,5 +47,5 @@ package() {
}
sha512sums="
-8620fca3dff53901d91dc791c080d278ba7ab3ceecf9ad116b7ded76d8b88529afe2c06978a4b563225d11205979c4f5be8d1e84c865dd9e5ab64066bdd1503e kcalc-22.08.0.tar.xz
+bf2b0d8420f0021428174a111abcc17cf0209dae30b635f52a7d166d5917185bdce2100b278b94797c643e876987397e953dc622e99cf2ab158d4e76351f4bc0 kcalc-24.02.2.tar.xz
"