aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcalc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcalc/APKBUILD')
-rw-r--r--community/kcalc/APKBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/community/kcalc/APKBUILD b/community/kcalc/APKBUILD
index f4f3b1b52c2..3e0eb419405 100644
--- a/community/kcalc/APKBUILD
+++ b/community/kcalc/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcalc
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.kcalc"
pkgdesc="Scientific Calculator"
license="GPL-2.0-or-later"
@@ -18,26 +20,26 @@ makedepends="
kdoctools-dev
kguiaddons-dev
ki18n-dev
- kinit-dev
knotifications-dev
kxmlgui-dev
mpfr-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcalc-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/kcalc.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcalc-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -45,5 +47,5 @@ package() {
}
sha512sums="
-d9fa03aabd471de4052cbf70209420634f1fdb18b533c55207b1a363b14e77a0078ccdf42515c5c2c49c5f87c4d230a041ebc8fb7739874721b83caccf83a0b3 kcalc-21.08.3.tar.xz
+bf2b0d8420f0021428174a111abcc17cf0209dae30b635f52a7d166d5917185bdce2100b278b94797c643e876987397e953dc622e99cf2ab158d4e76351f4bc0 kcalc-24.02.2.tar.xz
"