aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcalc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcalc/APKBUILD')
-rw-r--r--community/kcalc/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/community/kcalc/APKBUILD b/community/kcalc/APKBUILD
index 43b499419a2..f4ffeae803b 100644
--- a/community/kcalc/APKBUILD
+++ b/community/kcalc/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcalc
-pkgver=21.04.2
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x blocked by kxmlgui
-arch="all !armhf !s390x !mips64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.kcalc"
pkgdesc="Scientific Calculator"
license="GPL-2.0-or-later"
@@ -18,32 +20,32 @@ makedepends="
kdoctools-dev
kguiaddons-dev
ki18n-dev
- kinit-dev
knotifications-dev
kxmlgui-dev
mpfr-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcalc-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/kcalc.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcalc-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
sha512sums="
-c07d09d155d90d1081f09518955f10a0db80539072895b2f1f92ad60126b21f8ac2d4bb197329bb9c4b030a56a60ab91df9b7405daa3e17d2c8ef9abbf4a9f0b kcalc-21.04.2.tar.xz
+90a82bd7cd642ef4fb6bd4058d3a4abcddc88543ce85712f2b70f234c862ecd415bb585d65f26f2705ceeaded893d443eb1b1c9ea65e78648c3cc9b1b623e234 kcalc-24.02.1.tar.xz
"