aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcalc/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcalc/APKBUILD')
-rw-r--r--community/kcalc/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/community/kcalc/APKBUILD b/community/kcalc/APKBUILD
index a82197f0e37..3e0eb419405 100644
--- a/community/kcalc/APKBUILD
+++ b/community/kcalc/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcalc
-pkgver=22.04.1
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.kcalc"
pkgdesc="Scientific Calculator"
license="GPL-2.0-or-later"
@@ -18,15 +20,15 @@ makedepends="
kdoctools-dev
kguiaddons-dev
ki18n-dev
- kinit-dev
knotifications-dev
kxmlgui-dev
mpfr-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcalc-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/utilities/kcalc.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcalc-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -37,8 +39,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -46,5 +47,5 @@ package() {
}
sha512sums="
-3299c10cf0274d59d32b2089b40a4c93162d002c197ddb9e1b4dab1ef800f2607ee701a9dde188b7f81d52d38ec7b09c872dd279401df0cd4de37505ca23ef9d kcalc-22.04.1.tar.xz
+bf2b0d8420f0021428174a111abcc17cf0209dae30b635f52a7d166d5917185bdce2100b278b94797c643e876987397e953dc622e99cf2ab158d4e76351f4bc0 kcalc-24.02.2.tar.xz
"