aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcalendarcore/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcalendarcore/APKBUILD')
-rw-r--r--community/kcalendarcore/APKBUILD40
1 files changed, 28 insertions, 12 deletions
diff --git a/community/kcalendarcore/APKBUILD b/community/kcalendarcore/APKBUILD
index 6ed27060ce4..b6088162cca 100644
--- a/community/kcalendarcore/APKBUILD
+++ b/community/kcalendarcore/APKBUILD
@@ -1,23 +1,39 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kcalendarcore
-pkgver=5.84.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="The KDE calendar access library"
-options="!check" # RecursOn-ConnectDaily(2|3|6) make the builders stuck
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later"
-depends_dev="qt5-qtbase-dev libical-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcalendarcore-$pkgver.tar.xz"
+depends_dev="
+ libical-dev
+ qt6-qtbase-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ graphviz
+ qt6-qttools-dev
+ samurai
+ "
+checkdepends="
+ perl
+ xvfb-run
+ "
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/kcalendarcore.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcalendarcore-$pkgver.tar.xz"
replaces="kcalcore"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -25,14 +41,14 @@ build() {
}
check() {
- cd build
# testrecurtodo, testreadrecurrenceid, testicaltimezones, testmemorycalendar and testtimesininterval are broken
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "test(recurtodo|readrecurrenceid|icaltimezones|memorycalendar|timesininterval)"
+ xvfb-run ctest --test-dir build --output-on-failure -E "(RecursOn|test(readrecurrenceid|icaltimezones|memorycalendar|timesininterval|dateserialization|incidence|icalformat|identical|startdatetimesfordate|occurrenceiterator))"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-9e01ae59b1fe8dbeccb718aec99a62de17dffb25bdb991b2a77697af4741901f2a5028fd83a7c7119f48d2c3f37a68a9ab346622f34b230b0799de4b39174065 kcalendarcore-5.84.0.tar.xz
+f7390829497719d7a3be9fadb24807bbc510856bf5aefcf50bd44e90031b9889e5aeb275bc7787f0889a0404ebf3c00819116c1403b54188f739050011a35e85 kcalendarcore-6.1.0.tar.xz
"