aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcalendarcore/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcalendarcore/APKBUILD')
-rw-r--r--community/kcalendarcore/APKBUILD40
1 files changed, 28 insertions, 12 deletions
diff --git a/community/kcalendarcore/APKBUILD b/community/kcalendarcore/APKBUILD
index adc64946296..0f9527a3d03 100644
--- a/community/kcalendarcore/APKBUILD
+++ b/community/kcalendarcore/APKBUILD
@@ -1,23 +1,39 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kcalendarcore
-pkgver=5.87.0
+pkgver=6.0.0
pkgrel=0
pkgdesc="The KDE calendar access library"
-options="!check" # RecursOn-ConnectDaily(2|3|6) make the builders stuck
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
license="LGPL-2.0-or-later"
-depends_dev="qt5-qtbase-dev libical-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcalendarcore-$pkgver.tar.xz"
+depends_dev="
+ libical-dev
+ qt6-qtbase-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ graphviz
+ qt6-qttools-dev
+ samurai
+ "
+checkdepends="
+ perl
+ xvfb-run
+ "
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/kcalendarcore.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcalendarcore-$pkgver.tar.xz"
replaces="kcalcore"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -25,14 +41,14 @@ build() {
}
check() {
- cd build
# testrecurtodo, testreadrecurrenceid, testicaltimezones, testmemorycalendar and testtimesininterval are broken
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "test(recurtodo|readrecurrenceid|icaltimezones|memorycalendar|timesininterval)"
+ xvfb-run ctest --test-dir build --output-on-failure -E "(RecursOn|test(readrecurrenceid|icaltimezones|memorycalendar|timesininterval|dateserialization|incidence|icalformat|identical|startdatetimesfordate|occurrenceiterator))"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-97172e23a5119a37c7f6374cadbab58c55e4bc195e38bb74fb26aa0249f5ecbb00ffbf5889187f195d598b9654be08be0b78eae1b9f89b18f969f76c0e53d28f kcalendarcore-5.87.0.tar.xz
+30a0b2edbc46a11f76cfab65ddaf0ec5df96a4e7898d4cde5a24855b1b2aae37fd97dff688cfc81c516045d0c9253af6bf408a91bc3e6c4baba04fdb49b35f81 kcalendarcore-6.0.0.tar.xz
"