aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcalutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcalutils/APKBUILD')
-rw-r--r--community/kcalutils/APKBUILD20
1 files changed, 13 insertions, 7 deletions
diff --git a/community/kcalutils/APKBUILD b/community/kcalutils/APKBUILD
index c0586b14a94..815e00584af 100644
--- a/community/kcalutils/APKBUILD
+++ b/community/kcalutils/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcalutils
-pkgver=22.04.2
+pkgver=24.02.2
pkgrel=0
pkgdesc="The KDE calendar utility library"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kconfigwidgets
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://api.kde.org/kdepim/kcalutils/html"
license="LGPL-2.0-or-later"
depends_dev="
@@ -19,13 +21,17 @@ depends_dev="
ki18n-dev
kiconthemes-dev
kidentitymanagement-dev
+ ktexttemplate-dev
kwidgetsaddons-dev
+ "
+makedepends="$depends_dev
+ extra-cmake-modules
samurai
"
-makedepends="$depends_dev extra-cmake-modules"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcalutils-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/kcalutils.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcalutils-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -47,5 +53,5 @@ package() {
}
sha512sums="
-ec73027eb44ed10f604be43cf619092c3dff585745a4aeef5122952ce0f59b29c95a77b391f99c4ae596cf9f1f54360d1ba7b07f244757c1fcb3fe42f74988ae kcalutils-22.04.2.tar.xz
+9c6642e79da6749065e76cfb3ec8c316d413bf2897ec19b92350bfb35ccc70ffe94f1afa747f0d8effd11b8767c6cc2ae6a022c142301dbc88fd49f76771382e kcalutils-24.02.2.tar.xz
"