aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcalutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcalutils/APKBUILD')
-rw-r--r--community/kcalutils/APKBUILD26
1 files changed, 17 insertions, 9 deletions
diff --git a/community/kcalutils/APKBUILD b/community/kcalutils/APKBUILD
index d84f44d22b9..815e00584af 100644
--- a/community/kcalutils/APKBUILD
+++ b/community/kcalutils/APKBUILD
@@ -1,12 +1,14 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcalutils
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
pkgdesc="The KDE calendar utility library"
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kconfigwidgets
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://api.kde.org/kdepim/kcalutils/html"
license="LGPL-2.0-or-later"
depends_dev="
@@ -19,16 +21,21 @@ depends_dev="
ki18n-dev
kiconthemes-dev
kidentitymanagement-dev
+ ktexttemplate-dev
kwidgetsaddons-dev
"
-makedepends="$depends_dev extra-cmake-modules"
+makedepends="$depends_dev
+ extra-cmake-modules
+ samurai
+ "
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcalutils-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+_repo_url="https://invent.kde.org/pim/kcalutils.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcalutils-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
@@ -44,6 +51,7 @@ check() {
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-8f006faff5101ca776f6531250fd232674514d81febc9931741fd87b49a05d3f5b3f997a97551e5c57ad14d38e66697010a3e6751c9cde5ed8bae46460912878 kcalutils-21.08.3.tar.xz
+9c6642e79da6749065e76cfb3ec8c316d413bf2897ec19b92350bfb35ccc70ffe94f1afa747f0d8effd11b8767c6cc2ae6a022c142301dbc88fd49f76771382e kcalutils-24.02.2.tar.xz
"