aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcat/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcat/APKBUILD')
-rw-r--r--community/kcat/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/community/kcat/APKBUILD b/community/kcat/APKBUILD
index 6a366f83628..6253bf659a2 100644
--- a/community/kcat/APKBUILD
+++ b/community/kcat/APKBUILD
@@ -1,24 +1,31 @@
# Contributor: Andrey Pustovetov <andrey.pustovetov@gmail.com>
# Maintainer: Andrey Pustovetov <andrey.pustovetov@gmail.com>
pkgname=kcat
-pkgver=1.7.0
-pkgrel=0
+pkgver=1.7.1
+pkgrel=2
pkgdesc="Generic command-line non-JVM Apache Kafka producer and consumer"
-url="https://github.com/edenhill/kafkacat"
-arch="all"
-makedepends="bash yajl-dev librdkafka-dev"
+url="https://github.com/edenhill/kcat"
+# 32-bit: libserdes
+arch="all !x86 !armhf !armv7"
+makedepends="
+ bash
+ librdkafka-dev
+ libserdes-dev
+ yajl-dev
+ "
license="BSD-2-Clause"
options="!check" # upstream doesn't have a test suite
-source="$pkgname-$pkgver.tar.gz::https://github.com/edenhill/kafkacat/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/edenhill/kcat/archive/$pkgver.tar.gz"
# Backwards compatibility
replaces="kafkacat"
provides="kafkacat=$pkgver-r$pkgrel"
build() {
- ./configure \
+ bash ./configure \
--prefix=/usr \
--mandir=/usr/share/man \
+ --enable-avro \
--enable-json
make
}
@@ -28,5 +35,5 @@ package() {
}
sha512sums="
-1bb442600e031baf433ef0e864a36b0d5d785127cfe811e4132b929ac06956641f5f4054d8edce26a4f1cba7b11c610a09ea76c5a2cfcda82f6fc5f5aada9424 kcat-1.7.0.tar.gz
+07aa442a840819ca8d1ab20d86fe9d07afee0e4fa546b033ceb0c1c526f3fb5d9fbd2c34c29460d3439c5046b836605150dc76e85072d9516d82b9a193a0a3cd kcat-1.7.1.tar.gz
"