aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcharselect/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcharselect/APKBUILD')
-rw-r--r--community/kcharselect/APKBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/community/kcharselect/APKBUILD b/community/kcharselect/APKBUILD
index 059cb97163d..de911bdb73e 100644
--- a/community/kcharselect/APKBUILD
+++ b/community/kcharselect/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcharselect
-pkgver=21.12.1
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.kcharselect"
pkgdesc="A tool to select special characters from all installed fonts and copy them into the clipboard"
license="GPL-2.0-or-later"
@@ -17,23 +19,23 @@ makedepends="
ki18n-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcharselect-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/utilities/kcharselect.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcharselect-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -41,5 +43,5 @@ package() {
}
sha512sums="
-58b3a172e1ca81f1d6467e5634a5294988bb22ed505cce968dcc1e7eca2cb9a0d2ab2e1f6a109122d45946e8610b548c1091e4cb629f98fcbac2da642d14456d kcharselect-21.12.1.tar.xz
+7d8d493513554a48f1e2c5cf4484d91a3b1fc988bc659a1a4e05256898725dd3feee4f91894cdcc72df8d7417231fa131ba7161c79edef836bedb94301385765 kcharselect-24.02.1.tar.xz
"