aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcharselect/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcharselect/APKBUILD')
-rw-r--r--community/kcharselect/APKBUILD26
1 files changed, 14 insertions, 12 deletions
diff --git a/community/kcharselect/APKBUILD b/community/kcharselect/APKBUILD
index 7b4182c218b..95be5718f10 100644
--- a/community/kcharselect/APKBUILD
+++ b/community/kcharselect/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcharselect
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/utilities/org.kde.kcharselect"
pkgdesc="A tool to select special characters from all installed fonts and copy them into the clipboard"
license="GPL-2.0-or-later"
@@ -17,23 +19,23 @@ makedepends="
ki18n-dev
kwidgetsaddons-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcharselect-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/utilities/kcharselect.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcharselect-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -41,5 +43,5 @@ package() {
}
sha512sums="
-39c53cba81bcc8cecd37873c148e6a4948e16d0c5dbdee15c4dcee9681ec1644e2a9ebe897b06d7af16d467f1c46f3e32e31b0fea7d210a78500759589fc809c kcharselect-21.08.3.tar.xz
+a4bde33768778938bb2f60e4e929657d127b5c95810e5f6b0266a0114866637f79980901a592cb6ae6bb6105aaef7a6f8112cd065a950d76fcbbf3d6c24c109c kcharselect-24.02.2.tar.xz
"