aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcmutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcmutils/APKBUILD')
-rw-r--r--community/kcmutils/APKBUILD48
1 files changed, 35 insertions, 13 deletions
diff --git a/community/kcmutils/APKBUILD b/community/kcmutils/APKBUILD
index db30d0022d9..75bd614c10b 100644
--- a/community/kcmutils/APKBUILD
+++ b/community/kcmutils/APKBUILD
@@ -1,21 +1,43 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kcmutils
-pkgver=5.82.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Utilities for interacting with KCModules"
-arch="all !armhf !mips64 !s390x" # armhf blocked by extra-cmake-modules and mips64, s390x blocked by polkit
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
-depends_dev="kitemviews-dev kconfigwidgets-dev kcoreaddons-dev ki18n-dev kiconthemes-dev kservice-dev kxmlgui-dev kdeclarative-dev"
-makedepends="$depends_dev extra-cmake-modules doxygen qt5-qttools-dev"
-checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcmutils-$pkgver.tar.xz"
+depends_dev="
+ kconfigwidgets-dev
+ kcoreaddons-dev
+ kdeclarative-dev
+ ki18n-dev
+ kiconthemes-dev
+ kitemviews-dev
+ kservice-dev
+ kxmlgui-dev
+ "
+makedepends="$depends_dev
+ doxygen
+ extra-cmake-modules
+ qt6-qttools-dev
+ samurai
+ "
+checkdepends="
+ kirigami
+ xvfb-run
+ "
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kcmutils.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcmutils-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -23,13 +45,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure -E "kcmultidialogtest"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-709294fbbbaabf31384753651a320069e6779d101dbbec94ba09ae95146344989e854cab5fdd39510c300e026f113a156fe43d3b2fa57191851c95709a1997e4 kcmutils-5.82.0.tar.xz
+676724395781a44a57d224b55a36b9afa450ce502b0a6bd24127d5e638dbfcfc3165ebe7ccf10bf40460fde80d189058cd9f5fa17527b07d573ef97984ccf7a6 kcmutils-6.1.0.tar.xz
"