aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcodecs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcodecs/APKBUILD')
-rw-r--r--community/kcodecs/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/community/kcodecs/APKBUILD b/community/kcodecs/APKBUILD
index 414b59a8140..30bd1312290 100644
--- a/community/kcodecs/APKBUILD
+++ b/community/kcodecs/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kcodecs
-pkgver=5.95.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Provide a collection of methods to manipulate strings using various encodings"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -12,12 +15,13 @@ makedepends="
extra-cmake-modules
gperf
graphviz
- qt5-qttools-dev
+ qt6-qttools-dev
samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcodecs-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kcodecs.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcodecs-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -29,8 +33,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "(rfc2047|kcharsets)test"
+ xvfb-run ctest --test-dir build --output-on-failure build -E "(rfc2047|kcharsets)test"
}
package() {
@@ -38,5 +41,5 @@ package() {
}
sha512sums="
-b802ba6b6ceaae8b1272d7f0f2cc33e76f62de4e35e09e841e94010da25b1acf8372d4bcf69167365f1147a2f356748ec8418bef5a2d54874cd14ff73ab5014b kcodecs-5.95.0.tar.xz
+a2eb61b15849270df76ea78bbf289ca32792b6fc9b6710cd146a09eff36e7d4ff4dc1540a2baef59f29c1949cd5a5887064d9d070754c4987a6aa3ed0d4d5451 kcodecs-6.1.0.tar.xz
"