aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcodecs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcodecs/APKBUILD')
-rw-r--r--community/kcodecs/APKBUILD22
1 files changed, 13 insertions, 9 deletions
diff --git a/community/kcodecs/APKBUILD b/community/kcodecs/APKBUILD
index 0b5881360b8..3960553090e 100644
--- a/community/kcodecs/APKBUILD
+++ b/community/kcodecs/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kcodecs
-pkgver=5.90.0
+pkgver=6.0.0
pkgrel=0
pkgdesc="Provide a collection of methods to manipulate strings using various encodings"
arch="all !armhf" # armhf blocked by extra-cmake-modules
@@ -12,15 +15,17 @@ makedepends="
extra-cmake-modules
gperf
graphviz
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcodecs-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kcodecs.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcodecs-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -28,8 +33,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure build -E "(rfc2047|kcharsets)test"
}
package() {
@@ -37,5 +41,5 @@ package() {
}
sha512sums="
-02529703c073d9eeaf5755b3265e620e73da7873cefca91881ca9a451b6363d1f75101b7150615d5401450b013a90a05a83c24cc0ded0a897c319940311d792f kcodecs-5.90.0.tar.xz
+0e7260a8fb7cfdb95fefd0f3cc5d606525df48cc87cfc04a1c5b9b3ff111f8677609d625bee516c64c380b4456626423149969014df10a59e54baf45b35e99f0 kcodecs-6.0.0.tar.xz
"