aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcodecs/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcodecs/APKBUILD')
-rw-r--r--community/kcodecs/APKBUILD32
1 files changed, 22 insertions, 10 deletions
diff --git a/community/kcodecs/APKBUILD b/community/kcodecs/APKBUILD
index f518edc2d10..30bd1312290 100644
--- a/community/kcodecs/APKBUILD
+++ b/community/kcodecs/APKBUILD
@@ -1,19 +1,31 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kcodecs
-pkgver=5.84.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Provide a collection of methods to manipulate strings using various encodings"
arch="all !armhf" # armhf blocked by extra-cmake-modules
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
-makedepends="extra-cmake-modules qt5-qttools-dev gperf doxygen"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcodecs-$pkgver.tar.xz"
+makedepends="
+ doxygen
+ extra-cmake-modules
+ gperf
+ graphviz
+ qt6-qttools-dev
+ samurai
+ "
+checkdepends="xvfb-run"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kcodecs.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcodecs-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -21,13 +33,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ xvfb-run ctest --test-dir build --output-on-failure build -E "(rfc2047|kcharsets)test"
}
package() {
- DESTDIR="$pkgdir" cmake --build build --target install
+ DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-96b56a9388998cdffed4133a920325dd469cdd6fa14e86517886f0818f60e2a5933ab16a7bf039dc299c43a58acc3d1b7c3ef89e5d66027991a3e2262fc14ef8 kcodecs-5.84.0.tar.xz
+a2eb61b15849270df76ea78bbf289ca32792b6fc9b6710cd146a09eff36e7d4ff4dc1540a2baef59f29c1949cd5a5887064d9d070754c4987a6aa3ed0d4d5451 kcodecs-6.1.0.tar.xz
"