aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcolorchooser/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcolorchooser/APKBUILD')
-rw-r--r--community/kcolorchooser/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/community/kcolorchooser/APKBUILD b/community/kcolorchooser/APKBUILD
index bb06db43a53..53dda59a2d0 100644
--- a/community/kcolorchooser/APKBUILD
+++ b/community/kcolorchooser/APKBUILD
@@ -1,11 +1,13 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcolorchooser
-pkgver=22.04.2
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kxmlgui
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/graphics/org.kde.kcolorchooser"
pkgdesc="A color palette tool, used to mix colors and create custom color palettes"
license="MIT"
@@ -13,12 +15,12 @@ makedepends="
extra-cmake-modules
ki18n-dev
kxmlgui-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcolorchooser-$pkgver.tar.xz"
subpackages="$pkgname-lang"
-options="!check" # No tests
+_repo_url="https://invent.kde.org/graphics/kcolorchooser.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcolorchooser-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -29,8 +31,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -38,5 +39,5 @@ package() {
}
sha512sums="
-611a841fd971f24dd461d13db5ab7d7bec7c12494f07056e87890c6a5743238e8ef55551e8f22b9b5ae54dcb98ae93f71c5e611fab69cf032c40d6c5bf9c8e99 kcolorchooser-22.04.2.tar.xz
+faae6c9b26300d28721bec72f0b9295b5454984971de3c3cea12b491ff9e7104c3cb6752beca4791308f335d7bf396d2683da38c4396195970e4bb01817bc760 kcolorchooser-24.02.1.tar.xz
"