aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcolorchooser/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcolorchooser/APKBUILD')
-rw-r--r--community/kcolorchooser/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/community/kcolorchooser/APKBUILD b/community/kcolorchooser/APKBUILD
new file mode 100644
index 00000000000..4b7e9d75d3d
--- /dev/null
+++ b/community/kcolorchooser/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
+pkgname=kcolorchooser
+pkgver=24.02.2
+pkgrel=0
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
+url="https://kde.org/applications/graphics/org.kde.kcolorchooser"
+pkgdesc="A color palette tool, used to mix colors and create custom color palettes"
+license="MIT"
+makedepends="
+ extra-cmake-modules
+ ki18n-dev
+ kxmlgui-dev
+ qt6-qtbase-dev
+ samurai
+ "
+subpackages="$pkgname-lang"
+_repo_url="https://invent.kde.org/graphics/kcolorchooser.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcolorchooser-$pkgver.tar.xz"
+
+build() {
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ cmake --build build
+}
+
+check() {
+ ctest --test-dir build --output-on-failure
+}
+
+package() {
+ DESTDIR="$pkgdir" cmake --install build
+}
+
+sha512sums="
+c30c9e1e62d51b958d06c91e6dda4c667d9945e874b696a6f7a32562b7deee299b399a1427774c9d6a646c73796cc2c0166834c1f2c5385b3feeaa78f9f1564a kcolorchooser-24.02.2.tar.xz
+"