aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcompletion/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcompletion/APKBUILD')
-rw-r--r--community/kcompletion/APKBUILD18
1 files changed, 11 insertions, 7 deletions
diff --git a/community/kcompletion/APKBUILD b/community/kcompletion/APKBUILD
index 907d34ce228..dbdd0e5b116 100644
--- a/community/kcompletion/APKBUILD
+++ b/community/kcompletion/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kcompletion
-pkgver=5.95.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Text completion helpers and widgets"
# armhf blocked by extra-cmake-modules
@@ -9,6 +12,7 @@ arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
+ kcodecs-dev
kconfig-dev
kwidgetsaddons-dev
"
@@ -16,12 +20,13 @@ makedepends="$depends_dev
doxygen
extra-cmake-modules
graphviz
- qt5-qttools-dev
+ qt6-qttools-dev
samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcompletion-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kcompletion.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcompletion-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -33,8 +38,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -42,5 +46,5 @@ package() {
}
sha512sums="
-718c6c5d88564e6a50758f1b1c99091d370a4ef572962b0c38446ac57ccf79899002901fb88b78f38f819a6451219a9adb79f045d1c5e5a383d8443473304730 kcompletion-5.95.0.tar.xz
+a9732b69a85cad3b300219b08020a1701b6cfb44a841e8474204bf4b30b5f254ccffa5fa14646641e675b9f2a60fb2b8d0533130b83b8db932ef5e3f3bff92c0 kcompletion-6.1.0.tar.xz
"