aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcompletion/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcompletion/APKBUILD')
-rw-r--r--community/kcompletion/APKBUILD23
1 files changed, 14 insertions, 9 deletions
diff --git a/community/kcompletion/APKBUILD b/community/kcompletion/APKBUILD
index 4ad9d0b16e6..dbdd0e5b116 100644
--- a/community/kcompletion/APKBUILD
+++ b/community/kcompletion/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kcompletion
-pkgver=5.90.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Text completion helpers and widgets"
# armhf blocked by extra-cmake-modules
@@ -9,6 +12,7 @@ arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
+ kcodecs-dev
kconfig-dev
kwidgetsaddons-dev
"
@@ -16,15 +20,17 @@ makedepends="$depends_dev
doxygen
extra-cmake-modules
graphviz
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcompletion-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kcompletion.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcompletion-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -32,8 +38,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
@@ -41,5 +46,5 @@ package() {
}
sha512sums="
-c3a793fe565641d282326f82f9261f8a181f83afbf52ea5c82d418af343766ae012f4df5fda7f578438b41029846aa507fa6358140113073ca796f4c012ff6de kcompletion-5.90.0.tar.xz
+a9732b69a85cad3b300219b08020a1701b6cfb44a841e8474204bf4b30b5f254ccffa5fa14646641e675b9f2a60fb2b8d0533130b83b8db932ef5e3f3bff92c0 kcompletion-6.1.0.tar.xz
"