aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcompletion/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcompletion/APKBUILD')
-rw-r--r--community/kcompletion/APKBUILD28
1 files changed, 18 insertions, 10 deletions
diff --git a/community/kcompletion/APKBUILD b/community/kcompletion/APKBUILD
index a6ea6d209ad..dbdd0e5b116 100644
--- a/community/kcompletion/APKBUILD
+++ b/community/kcompletion/APKBUILD
@@ -1,28 +1,36 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kcompletion
-pkgver=5.84.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Text completion helpers and widgets"
-arch="all !armhf" # armhf blocked by extra-cmake-modules
+# armhf blocked by extra-cmake-modules
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-or-later"
depends_dev="
+ kcodecs-dev
kconfig-dev
kwidgetsaddons-dev
"
makedepends="$depends_dev
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ graphviz
+ qt6-qttools-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcompletion-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kcompletion.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcompletion-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -30,13 +38,13 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest
+ xvfb-run ctest --test-dir build --output-on-failure
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-fd30f997079d17719534969addaa96d99b21774fc1310adfb8a07720b3ddeec179a98a8bf3162d813fff46dcf429e712d6122eaca0e0afe00befe0e32da22ed0 kcompletion-5.84.0.tar.xz
+a9732b69a85cad3b300219b08020a1701b6cfb44a841e8474204bf4b30b5f254ccffa5fa14646641e675b9f2a60fb2b8d0533130b83b8db932ef5e3f3bff92c0 kcompletion-6.1.0.tar.xz
"