aboutsummaryrefslogtreecommitdiffstats
path: root/community/kconfigwidgets/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kconfigwidgets/APKBUILD')
-rw-r--r--community/kconfigwidgets/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/kconfigwidgets/APKBUILD b/community/kconfigwidgets/APKBUILD
index 2210759254e..1071b51f1bd 100644
--- a/community/kconfigwidgets/APKBUILD
+++ b/community/kconfigwidgets/APKBUILD
@@ -1,17 +1,20 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kconfigwidgets
-pkgver=5.94.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Widgets for KConfig"
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://community.kde.org/Frameworks"
license="LGPL-2.1-only AND LGPL-2.1-or-later"
depends_dev="
kauth-dev
kcodecs-dev
+ kcolorscheme-dev
kconfig-dev
kcoreaddons-dev
kguiaddons-dev
@@ -23,12 +26,13 @@ makedepends="$depends_dev
extra-cmake-modules
graphviz
kdoctools-dev
- qt5-qttools-dev
+ qt6-qttools-dev
samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kconfigwidgets-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/frameworks/kconfigwidgets.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kconfigwidgets-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -40,8 +44,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "kstandardactiontest"
+ xvfb-run ctest --test-dir build --output-on-failure -E "(kstandardaction|klanguagename)test"
}
package() {
@@ -49,5 +52,5 @@ package() {
}
sha512sums="
-1b99bb215d6f00204e6605cc078062d3e6d9b8c3e5b4a2166e82aaf1a50ac02bbede955908bb7c3bd04e6d1733b103f4e50850358d462d3568bd59f8cf43d02e kconfigwidgets-5.94.0.tar.xz
+546c4399537d6b65a58c4fe302bd7d3186161b10fe38b008b42b344c57455941e0d007d7a51fa4cec93fc9e404e2bfce39121b6810d6c45e8ac2c83751c1661a kconfigwidgets-6.1.0.tar.xz
"