aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcrash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcrash/APKBUILD')
-rw-r--r--community/kcrash/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/community/kcrash/APKBUILD b/community/kcrash/APKBUILD
index 6c4a35b360c..ae8c5f39293 100644
--- a/community/kcrash/APKBUILD
+++ b/community/kcrash/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kcrash
-pkgver=5.87.0
+pkgver=6.0.0
pkgrel=0
pkgdesc="Support for application crash analysis and bug report from apps"
arch="all !armhf"
@@ -14,15 +17,17 @@ depends_dev="
makedepends="$depends_dev
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcrash-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/kcrash.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcrash-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -30,15 +35,14 @@ build() {
}
check() {
- cd build
-
# kcrashtest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "kcrashtest"
+ xvfb-run ctest --test-dir build --output-on-failure -E "kcrashtest"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-307c59dfb1b5c867d45c8b84b6e06050953e96f1423e63c9867e1d42d3df043704ac6b51098cd49f2f7b7dd37bdd57b86bc027137766abbefc9b7b7c26053f25 kcrash-5.87.0.tar.xz
+694d7a8fd266c66d76d4049176a6212f660383c39a3c8fd065c58a27c3daf97f80444f84fddcf39b13754fd2c7adfca59f20c6d4791d9dd71eb07389b6f29c99 kcrash-6.0.0.tar.xz
"