aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcrash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcrash/APKBUILD')
-rw-r--r--community/kcrash/APKBUILD18
1 files changed, 10 insertions, 8 deletions
diff --git a/community/kcrash/APKBUILD b/community/kcrash/APKBUILD
index 9b9c83c6a78..286683619bd 100644
--- a/community/kcrash/APKBUILD
+++ b/community/kcrash/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kcrash
-pkgver=5.95.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Support for application crash analysis and bug report from apps"
arch="all !armhf"
@@ -14,12 +17,13 @@ depends_dev="
makedepends="$depends_dev
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ qt6-qttools-dev
samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcrash-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/kcrash.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcrash-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -31,10 +35,8 @@ build() {
}
check() {
- cd build
-
# kcrashtest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "kcrashtest"
+ xvfb-run ctest --test-dir build --output-on-failure -E "kcrashtest"
}
package() {
@@ -42,5 +44,5 @@ package() {
}
sha512sums="
-704ad643a56101d514c68fadedb34657dfcb82fdf05ec787ac3679655dae7fb012aea564f430da1005fa54fb6edc442e48d4e5dc0ec24e9eb55475be986eca05 kcrash-5.95.0.tar.xz
+6334c6924e5f78f97cd433ea1d41f82db51fb3abc9205320d5c3ffd4034383d9bb2c1810cc71c7d3639e53294a819be2b96a53469d826d132f6faf2d49ed97a4 kcrash-6.1.0.tar.xz
"