aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcrash/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcrash/APKBUILD')
-rw-r--r--community/kcrash/APKBUILD24
1 files changed, 14 insertions, 10 deletions
diff --git a/community/kcrash/APKBUILD b/community/kcrash/APKBUILD
index 6c4a35b360c..286683619bd 100644
--- a/community/kcrash/APKBUILD
+++ b/community/kcrash/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kcrash
-pkgver=5.87.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Support for application crash analysis and bug report from apps"
arch="all !armhf"
@@ -14,15 +17,17 @@ depends_dev="
makedepends="$depends_dev
doxygen
extra-cmake-modules
- qt5-qttools-dev
+ qt6-qttools-dev
+ samurai
"
checkdepends="xvfb-run"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcrash-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-doc"
+_repo_url="https://invent.kde.org/frameworks/kcrash.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kcrash-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DBUILD_QCH=ON
@@ -30,15 +35,14 @@ build() {
}
check() {
- cd build
-
# kcrashtest is broken
- CTEST_OUTPUT_ON_FAILURE=TRUE xvfb-run ctest -E "kcrashtest"
+ xvfb-run ctest --test-dir build --output-on-failure -E "kcrashtest"
}
package() {
DESTDIR="$pkgdir" cmake --install build
}
+
sha512sums="
-307c59dfb1b5c867d45c8b84b6e06050953e96f1423e63c9867e1d42d3df043704ac6b51098cd49f2f7b7dd37bdd57b86bc027137766abbefc9b7b7c26053f25 kcrash-5.87.0.tar.xz
+6334c6924e5f78f97cd433ea1d41f82db51fb3abc9205320d5c3ffd4034383d9bb2c1810cc71c7d3639e53294a819be2b96a53469d826d132f6faf2d49ed97a4 kcrash-6.1.0.tar.xz
"