aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcron/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcron/APKBUILD')
-rw-r--r--community/kcron/APKBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/community/kcron/APKBUILD b/community/kcron/APKBUILD
index 6fdee55e548..0d6748080f7 100644
--- a/community/kcron/APKBUILD
+++ b/community/kcron/APKBUILD
@@ -1,37 +1,41 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcron
-pkgver=21.08.1
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/system/"
pkgdesc="Configure and schedule tasks"
license="GPL-2.0-or-later"
makedepends="
extra-cmake-modules
+ kcmutils-dev
kconfigwidgets-dev
kdoctools-dev
ki18n-dev
kiconthemes-dev
kio-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcron-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/system/kcron.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcron-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -39,5 +43,5 @@ package() {
}
sha512sums="
-987eebe24acb1ab00ffebf0d648ec313c75a55948054d5c8a3cab25cdcddfffbc3c472d3bed5ca03783c5c9794d02ba16a33218687823d485fbd27e442e9c107 kcron-21.08.1.tar.xz
+c5831600cebccae5bda77655db63fdc2e5b03caa0c919d02b38b93daeebc4926ff5df2c9a60d81efbdfdb97d5fdf56ee65452db68122a327f44517fdf785d115 kcron-24.02.1.tar.xz
"