aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcron/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcron/APKBUILD')
-rw-r--r--community/kcron/APKBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/community/kcron/APKBUILD b/community/kcron/APKBUILD
index 4a738c19903..0d6748080f7 100644
--- a/community/kcron/APKBUILD
+++ b/community/kcron/APKBUILD
@@ -1,26 +1,30 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcron
-pkgver=22.04.2
+pkgver=24.02.1
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/system/"
pkgdesc="Configure and schedule tasks"
license="GPL-2.0-or-later"
makedepends="
extra-cmake-modules
+ kcmutils-dev
kconfigwidgets-dev
kdoctools-dev
ki18n-dev
kiconthemes-dev
kio-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcron-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/system/kcron.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcron-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -31,8 +35,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -40,5 +43,5 @@ package() {
}
sha512sums="
-a8619b65f4473de95616d577fa6125da83012cb834a8674e4d958473f540d0ee9683b9a8a23b8f21464cce9f2adbe3d0066e3fc9ab2ffa598724d19d5e6fefd3 kcron-22.04.2.tar.xz
+c5831600cebccae5bda77655db63fdc2e5b03caa0c919d02b38b93daeebc4926ff5df2c9a60d81efbdfdb97d5fdf56ee65452db68122a327f44517fdf785d115 kcron-24.02.1.tar.xz
"