aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcron/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcron/APKBUILD')
-rw-r--r--community/kcron/APKBUILD23
1 files changed, 13 insertions, 10 deletions
diff --git a/community/kcron/APKBUILD b/community/kcron/APKBUILD
index 041450d2e09..1075febd0c0 100644
--- a/community/kcron/APKBUILD
+++ b/community/kcron/APKBUILD
@@ -1,26 +1,30 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcron
-pkgver=22.04.0
-pkgrel=1
+pkgver=24.02.2
+pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/system/"
pkgdesc="Configure and schedule tasks"
license="GPL-2.0-or-later"
makedepends="
extra-cmake-modules
+ kcmutils-dev
kconfigwidgets-dev
kdoctools-dev
ki18n-dev
kiconthemes-dev
kio-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcron-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/system/kcron.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcron-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -31,8 +35,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -40,5 +43,5 @@ package() {
}
sha512sums="
-a868ee9935cd3ace00db931801126bc33682ff9b4594a4d4f4b8229b06a2fe64d779ee696038cfaf7d9e6decfde73eca98de0823ae8df9aa81543a4ab061f6c3 kcron-22.04.0.tar.xz
+e4da9cf4ad032bfbc9b76a51fa1a5aca1b5c0c42ed38ca0b4e7cb8cb5fcbf9907e803b486b3bc9e9696f20bc5e4bd62289b93bf171a6b5055fcec0ea388bdcfa kcron-24.02.2.tar.xz
"