aboutsummaryrefslogtreecommitdiffstats
path: root/community/kcron/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kcron/APKBUILD')
-rw-r--r--community/kcron/APKBUILD26
1 files changed, 15 insertions, 11 deletions
diff --git a/community/kcron/APKBUILD b/community/kcron/APKBUILD
index d61cc87ca91..1075febd0c0 100644
--- a/community/kcron/APKBUILD
+++ b/community/kcron/APKBUILD
@@ -1,37 +1,41 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-applications
pkgname=kcron
-pkgver=21.08.3
+pkgver=24.02.2
pkgrel=0
# armhf blocked by extra-cmake-modules
-# s390x, mips64 and riscv64 blocked by polkit -> kio
-arch="all !armhf !s390x !mips64 !riscv64"
+arch="all !armhf"
url="https://kde.org/applications/system/"
pkgdesc="Configure and schedule tasks"
license="GPL-2.0-or-later"
makedepends="
extra-cmake-modules
+ kcmutils-dev
kconfigwidgets-dev
kdoctools-dev
ki18n-dev
kiconthemes-dev
kio-dev
- qt5-qtbase-dev
+ qt6-qtbase-dev
+ samurai
"
-source="https://download.kde.org/stable/release-service/$pkgver/src/kcron-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+_repo_url="https://invent.kde.org/system/kcron.git"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kcron-$pkgver.tar.xz"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ ctest --test-dir build --output-on-failure
}
package() {
@@ -39,5 +43,5 @@ package() {
}
sha512sums="
-0d566d7a045d505646c1d705e555b3d608c6245190a6854e9361fe6845669610b6399d47ea86f0746a8ca2c9ecdcc9641c801ad162814357e54fa137d5848478 kcron-21.08.3.tar.xz
+e4da9cf4ad032bfbc9b76a51fa1a5aca1b5c0c42ed38ca0b4e7cb8cb5fcbf9907e803b486b3bc9e9696f20bc5e4bd62289b93bf171a6b5055fcec0ea388bdcfa kcron-24.02.2.tar.xz
"