aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdb/APKBUILD')
-rw-r--r--community/kdb/APKBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/community/kdb/APKBUILD b/community/kdb/APKBUILD
index fab9591c5ee..ee8f3a14367 100644
--- a/community/kdb/APKBUILD
+++ b/community/kdb/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=kdb
pkgver=3.2.0
-pkgrel=4
+pkgrel=5
pkgdesc="Database connectivity and creation framework for various database vendors"
url="https://community.kde.org/KDb"
# armhf blocked by extra-cmake-modules
@@ -17,6 +17,7 @@ makedepends="
python3
qt5-qtbase-dev
qt5-qttools-dev
+ samurai
sqlite-dev
"
subpackages="$pkgname-dev $pkgname-lang $pkgname-sqlite $pkgname-mysql $pkgname-postgresql"
@@ -27,8 +28,8 @@ source="https://download.kde.org/stable/kdb/src/kdb-$pkgver.tar.xz
"
build() {
- cmake -B build \
- -DCMAKE_BUILD_TYPE=None \
+ cmake -B build -G Ninja \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DPYTHON_EXECUTABLE=/usr/bin/python3