aboutsummaryrefslogtreecommitdiffstats
path: root/community/kdbusaddons/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/kdbusaddons/APKBUILD')
-rw-r--r--community/kdbusaddons/APKBUILD19
1 files changed, 11 insertions, 8 deletions
diff --git a/community/kdbusaddons/APKBUILD b/community/kdbusaddons/APKBUILD
index 8b3ff3b9cc5..a1a7b1f340f 100644
--- a/community/kdbusaddons/APKBUILD
+++ b/community/kdbusaddons/APKBUILD
@@ -1,7 +1,10 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: team/kde <bribbers@disroot.org>
+
+# The group tag is just to easily find this APKBUILD by some scripts for automation
+# group=kde-frameworks
pkgname=kdbusaddons
-pkgver=5.95.0
+pkgver=6.1.0
pkgrel=0
pkgdesc="Addons to QtDBus"
# armhf blocked by extra-cmake-modules
@@ -12,13 +15,14 @@ makedepends="
doxygen
extra-cmake-modules
graphviz
- qt5-qttools-dev
+ qt6-qttools-dev
shared-mime-info
samurai
"
-source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kdbusaddons-$pkgver.tar.xz"
+checkdepends="dbus"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang"
-options="!check" # Requires running dbus-daemon
+_repo_url="https://invent.kde.org/frameworks/kdbusaddons.git"
+source="https://download.kde.org/stable/frameworks/${pkgver%.*}/kdbusaddons-$pkgver.tar.xz"
build() {
cmake -B build -G Ninja \
@@ -30,8 +34,7 @@ build() {
}
check() {
- cd build
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+ dbus-run-session -- ctest --test-dir build --output-on-failure
}
package() {
@@ -39,5 +42,5 @@ package() {
}
sha512sums="
-0d22a8bcda09e366e994370c9808d83f7b8b598cbd4c4b746f1c7953d5078ab2530a2e8372fc170475a66012c4337d5c2871e4e5e98e615500a907bdaa546aa2 kdbusaddons-5.95.0.tar.xz
+924d21179c624fdeed9de230c22b12d4682980b8578e81a8473bb95a1d251a104d5d6dd7e999e01caf5652a60a6b78ad2baf07e98d1d1d60c5ed2c4c7e6a844d kdbusaddons-6.1.0.tar.xz
"